Просмотров: 51362

Как в excel сделать чтобы сумма автоматически

Закрыть ... [X]

Excel одна из самых известных программ Microsoft. Область применения Excel не ограничивается построением элементарных таблиц.

Программа применяется для проведения экономических расчётов, построения диаграмм,в бухгалтерии её используют для автоматизирования таблиц, решения уравнений, в картографии, для вывода схем и чертежей

Содержание


Сложение в Excel

Изучение программы следует начать с примера сложения. Рассмотрим, как можно складывать в excel:

  • Для этого возьмём простой пример сложения чисел 6 и 5.

Берётся ячейка и в неё записывается пример«=6+5»

  • После нажать клавишу Enter.
  • Сумма«11»,отразится в той же ячейке. А строка формул покажет само равенство«=6+5».

Второй способ как в excel сложить числа:

Попробуем в excel сложить ячейки, разбросанные по таблице. Для этого выберем пример:

Нужно найти итоговое значение прибыли за 3 месяца за работы.

  • Следует выделить задуманные значения и нажать на значок ∑ автосумма в excel на вкладке ФОРМУЛЫ.
рис.1. На скриншоте эти цифры обведены зелёной рамкой, а значок ∑ Автосумма подсвечен зелёным цветом

Результат отразится в пустой ячейке в столбце Итого.

рис.2. Строка формул покажет«=СУММ(C2:E2)»

Чтобы найти значение остальных данных, нужно копировать формулу«=СУММ(C2:E2)», и поставить её в остальные ячейки столбика Итого. Таким способом можно посчитать в экселе сумму столбца автоматически. Точно также, можно в excel посчитать сумму времени.

Значения в таблицах могут поменяться, но формула в ячейке сохраняется прежней, что поможет посчитать формулу в экселе, не прилагая усилий и экономя время на дальнейшие расчёты.


Работа с функциями Excel

С помощью формул можно не только сделать сумму в экселе, но и делать выборку определённых значений, подчинённых конкретным условиям. Например, дана таблица с указанием наименования фруктов, их цены и веса.

Вот пример

Нужно подсчитать сумму ячеек где 1кг фруктов стоит меньше 100. Вручную этот процесс займёт время, ноExcel предлагает воспользоваться замечательной формулой–СУММЕСЛИМН. Что означает: найти сумму данных, если совпадает множество значений.

Задать алгоритм можно через вкладку Формулы, выбрать список математических функций и кликнуть мышкой по СУММЕСЛИМН. В ячейку нужно задать эту функцию и указать диапазон расчётов. Получим итоговое число 50. А в строке формул видим значение СУММЕСЛИМН (С2:С;В2:В5;«<100»).

Где, С2:С5 –столбец для суммировани яячеек, В2:В5–столбец для проверки условия«стоимость 1кг фруктов меньше 100».И«<100»—условие выборки.

Функция СУММЕСЛИМН поможет в excel автоматически считать данные, с более сложными критериями, и длина колонок будет иметь больше позиций.

Рассмотрим ещё одну формулу Excel, на примере таблицы про фрукты, но усложним задачу. Посчитаем наименование фруктов с ценой больше 90.Для этого воспользуемся формулой СЧЁТЕСЛИМН. Означающей,выполнить счёт, если задано много условий.

  • Во вкладке Функции в математическом списке кликаем по названию«СЧЁТЕСЛИМН». Выбираем критерии и заводим их в таблицу.
  • В ячейке получаем число2 , а в строке функций видим формулу«=СЧЁТЕСЛИМН(В2:В5;«>90»).
  • Где,(В2:В5) столбец для проверки заданных критериев,«>90» условие отбора.
Формула проверит каждую ячейку из заданного диапазона, и если та удовлетворит условию, то будет посчитана

Может потребоваться изменить значения, и выбрать дополнительные критерии. Например:В той же таблице требуется посчитать наименование фруктов со стоимостью больше 90 и определить их количество на складе по весу менее 20 кг.

Используется та же формула СЧЁТЕСЛИМН

После выборки формула изменится. Она примет вид«=СЧЁТЕСЛИМН (В2:В6;«>90»;С2:С6;«<20»).

Рассмотрим ещё один пример счёта в программе Excel. Задание: в списках на складе нужно изменить ценники.

Когда позиций не много это можно сделать, не прибегая к автоматическому счёту. Но бывают целые каталоги, в которых наименований больше тысячи. В таком случае поможет только Excel и его функция ВПР. Означающая Вертикальный просмотр в списке задания. Находиться ВПР во вкладке Функции и разделе"Ссылки и массивы". Нажимаем на функцию и помещаем её в ячейку.

Для примера снова используем таблицу с фруктами.

рис.1. Мы видим цены из первой колонки, которые нужно заменить на новые, отмеченные красным
рис.2. Выбираем ячейку В2 и записываем в неё формулу«=ВПР(А2;$D:$E;2)

А2–значение которое нужно заменить, $D:$E –означает полное выделение таблицы, «$»—знак, который ограничивает копирование не нужной информации во втором столбике D2:Е5.

Мы написали формулу только в одну ячейку точно также можно провести нужную выборку, просто скопировав функцию и поставив во все ячейки.

Вертикальный просмотр ведётся только в первой таблице по всем позициям столбика. В этом случае, поиск слова «яблоки» пройдёт по столбику D.

Когда ячейка А2 будет обнаружена, программа определит из какой колонки выбрать нужное значение. В данной таблице это колонка Е ,в которой помещены изменённые цены. Если колонок в таблице 10 и более, то для поиска опять берётся первая колонка, а вы записываете нужную вам формулу для выборки.

ПОСМОТРЕТЬ ВИДЕО

В программу заложено множество функций, чтобы разобраться со всеми потребуется много времени. Рассмотрим основные из них:

  1. СУММ–используют для нахождения суммарного значения столбцов и ячеек
  2. ЕСЛИ–используют для выявления сравнения нескольких показателей. Определяется значением Больше и Меньше.
  3. ПРОСМОТР–используют для нахождения нужного значения или для выборки определенного столбца.
  4. ДАТА–используется для возвращения числа дней между задуманными датами
  5. ВПР–используют как вертикальный просмотр в поиске значений.
  6. СЦЕПИТЬ–используют для соединения нескольких столбцов в один.
  7. РУБЛЬ–используют для преобразования числа в текст, используя денежный эквивалент рубль.
  8. СОВПАД–используют вовремя нахождения одинаковых текстовых значений
  9. СТРОЧН–используют для преобразования всех заглавных букв в строчные
  10. ПОВТОР–используют при повторе текста нужное число раз.

Статья содержит основные этапы работы с таблицами в excel. Рассмотрены методы сложения и выборки по заданным критериям.


Источник: http://pcyk.ru/program/excel-pomozhet-schitat-bystree-kalkulyatora/

Похожие новости


Поэтапно делать массаж
Раздвижные ворота своим руками
Как промыть котел своими руками
Что можно нарисовать на стене в комнате своими руками
Пошаговая инструкция как выйти замуж
Как сделать лизуна из зубной пасты и клей пва
Деревянный настил как сделать
Как сделать на газовым котле дымоход




ШОКИРУЮЩИЕ НОВОСТИ